Циклы» написать программу: 15 напишите программу, которая в последовательности целых чисел определяет количество положительных чисел, кратных двенадцати . программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом ноль (ноль – признак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. введенные числа по модулю не превышают 30000.

Pomogite20000p Pomogite20000p    3   21.05.2019 18:10    2

Ответы
AliceStilinski AliceStilinski  16.06.2020 14:53

а на каком языке программирования?

 

на JavaScript:

 

var i = 1; kratnoe = 0;

 

while ( i < 1000) {

 

i += 1;

 

if ( i % 12 == 0) {

kratnoe += 1;

}

 

}

 

alert (kratnoe);

ПОКАЗАТЬ ОТВЕТЫ
Патич232 Патич232  16.06.2020 14:53

uses crt;
var i,s:integer;
begin
s:=0;
repeat
write('Vvedite chislo: ');
readln(i);
if ((i>0) and (i mod 12 = 0)) then inc(s);
until ((i=0 ) and (i< 1001) and (abs(i)<=30000));
writeln('count ',s);
readln;
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика