tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Что-то подзабыл я pascal.
Что-то подзабыл я pascal. написать программу в pascal, которая складывает последние 4 цифры любого задаваемого числа.
рпипппит
2 04.10.2019 01:30
1
Ответы
irinavlasova
02.09.2020 15:49
Var a,s:integer;
begin
repeat readln(a) until a>9; // по условию число >9
s:=a mod 10; // забираем последнюю цифру
while a>9 do a:=a div 10; // вычеркиваем последнию цифру, пока а - двухзначное число
writeln(s+a mod 10) // теперь выводим сумму
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
aspier2016
20.05.2020 16:21
Постройте таблицу истинности для логического выражения (a v b) & (ā v b)...
Опз2
20.05.2020 16:23
Название программы для работы в Интернет...
menoralle
23.05.2019 05:10
1.в каком случае сообщение содержит информацию для конкретного человека,а а в каком - нет? 2. примеры обоих случаев...
alexeyivanovnk1234
23.05.2019 05:10
Скорость передачи данных через adsl-соединение равна 16384 байт/с.через данное соединение файл размером 1 мегабайт.определите время передачи файла в секундах....
anaraermus
23.05.2019 05:10
Вцветовой модели rgb для кодирования одного пикселя используется 3 бита. определите информационный размер фотографии размером 1024x2048 пикселей....
Nina34732
23.05.2019 05:00
Громкость звука изменилась на 10 дц, что происходит с амплитудой?...
КамбэкBTS
23.05.2019 04:50
Просто не ! нужно перевести число 503 из десятичной системы в пятеричную и сделать проверку, она у меня и не !...
AlinaVoronova
23.05.2019 04:40
Решите по информатике ато убьёт училка 8 класс если целое число m делится на целое число n то вывести частное от токого деления в противном случае вывести сообщение в не...
opuros33
23.05.2019 04:40
ответить на вопрос: «что запрещено делать при работе за компьютером»....
7IX
23.05.2019 04:40
Такое нужно примеры множества состоящго из 10 элементов...
Популярные вопросы
Бағала 26 АУЫЗ8. Адамның ойлап тапқандарының барлығы тек жақсылыку.қызмет...
2
Нужно написать эссе, на тему значение минеральных ресурсов для хозяйства...
1
5. Подпиши схему частей рекиозерогоры412ЗMope...
2
Дуже терміново. виконайте,будь ласка....
2
Сопоставьте верхушечные и боковые почки веточки шелковицы и абрикоса....
1
4.Выпиши предложения с обособленными членами. Графически выделиобособленные...
2
Раскажите о развитии земделелия у тюрков....
2
Число √2 соответствует какому из нижеследующих интервалов числа:...
2
Какие вопросы можно задать на тему пичугин мост? ...
1
Какое государство или племя захватил?Шитеми младший брат Бумына со 100000...
3
begin
repeat readln(a) until a>9; // по условию число >9
s:=a mod 10; // забираем последнюю цифру
while a>9 do a:=a div 10; // вычеркиваем последнию цифру, пока а - двухзначное число
writeln(s+a mod 10) // теперь выводим сумму
end.