Что-то мои попытки бессмысленны. язык паскаль. напишите программу, которая определяет, сколько в матрице есть k -значных чисел, сумма цифр каждого из которых кратна r . входные данные: в первой строке записаны через пробел размеры матрицы: количество строк n и количество столбцов m ( 1 ≤ n , m ≤ 100 ). в следующих n строках записаны строки матрицы, в каждой – по m натуральных чисел, разделённых пробелами. затем в отдельной строке вводятся числа k и r . выходные данные: программа должны вывести одно число – количество k -значных чисел, сумма цифр каждого из которых кратна r . примеры: входные данные: 5 5 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 2 3 выходные данные: 5

WirexiaEnderman WirexiaEnderman    1   16.07.2019 19:10    34

Ответы
Camall Camall  30.08.2020 18:58
// PascalABC.NET 3.0, сборка 1156 от 30.01.2016
begin
  var n,m:integer;
  Read(n,m);
  var a:array[,] of integer;
  SetLength(a,n,m);
  for var i:=0 to n-1 do
    for var j:=0 to m-1 do Read(a[i,j]);
  var k,r:integer;
  Read(k,r);
  var p:=0; //будущий результат
  foreach var x:integer in a do begin
    var s:=0; var q:=x; var k1:=0;
    while q<>0 do begin
      s:=s+(q mod 10); q:=q div 10; Inc(k1)
      end;
    if (k1=k) and (s mod r = 0) then Inc(p)
    end;
  Writeln(p)
end.

Тестовое решение:
5 5
1 2 3 4 5
6 7 8 9 10
11 12 13 14 15
16 17 18 19 20
21 22 23 24 25
2 3
5
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика