Чисел из последовательности натуральных чисел. Программа получает на вход натуральные числа, количество введённых чисел неизвестно (но не
менее двух), последовательность чисел заканчивается числом 0 (0 — признак
окончания ввода, не входит в последовательность). Количество чисел не
превышает 1000. Введённые числа не превышают 10 000.
Программа должна вывести одно число: произведение двух чисел, значения
которых в данной последовательности наименьшие.
Пример работы программы:
Входные данные
10
7
8
9
0
Выходные данные
56
РЕШИТЕ УМОЛЯЮ А ТО МНЕ ППЦ ОТ РОДИТЕЛЕЙ РЕШИТЕ

Yasenevo1036 Yasenevo1036    1   04.02.2021 18:10    3

Ответы
GeorgeFedorenko GeorgeFedorenko  06.03.2021 18:12

n1 = 9*99

n2 = 9*99

count = 0

while 1:

   a = int(input())

 

   if count < 2 and a == 0:

           print("минимум два числа")

           count -= 1

   elif  count == 1000:

       print("чисел не может быть больше 1000")

       break

   elif a > 10000:

       print("Число не может быть больше 10.000")

       count -= 1

   elif a == 0:

       break

   elif a < n1:

       n1 = a

   elif a < n2:

       n2 = a

   count += 1

print(n1*n2)


Чисел из последовательности натуральных чисел. Программа получает на вход натуральные числа, количес
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика