tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
(через pascal подпрограммы)
(через pascal подпрограммы) два треугольника заданы координатами вершин. определить, площадь какого из них больше (использовать функцию нахождения площади треугольника).
kristinaboss15
3 27.07.2019 04:40
4
Ответы
Nikaslavnikova
19.08.2020 18:16
Function Square(x1, y1, x2, y2, x3, y3: real): real;
begin
Square := abs((x2 - x1) * (y3 - y1) - (x3 - x1) * (y2 - y1)) / 2;
end;
var
x1, y1, x2, y2, x3, y3, s1, s2: real;
begin
write('Задайте первый треугольник(x1,y1,x2,y2,x3,y3): ');
readln(x1, y1, x2, y2, x3, y3);
s1 := Square(x1, y1, x2, y2, x3, y3);
write('Задайте второй треугольник(x1,y1,x2,y2,x3,y3): ');
readln(x1, y1, x2, y2, x3, y3);
s2 := Square(x1, y1, x2, y2, x3, y3);
if s1 > s2 then writeln('Площадь первого треугольника больше')
else if s1 < s2 then writeln('Площадь второго треугольника больше')
else writeln('Площади треугольников равны');
end.
p.s. проверять существуют ли такие треугольники не нужно, т.к. они уже заданы и нам нужно определить площадь большего.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
filltema
07.09.2020 22:17
Составьте программу, которая генерирует случайное четы- рехзначное число от 1000 до 9999 (номер автобусного билета), выводитего на экран и определяет, является ли билет «счастливым»...
losangelina23
24.12.2019 10:14
1. расшифрруйте пословицу. определите шаг шифрования.гжй урнк чнжг жёв2. допишите предложение, используя ключевые слова в таблице.растворное, векторное, фрактальное, пикселей, , -...
kotelnikovaLA
16.10.2020 22:59
1. Что такое EV3?2. Технические характеристики, установка аккумуляторов,3. Включение и отключение EV3, индикаторов и кнопок, какие порты?...
Бекки5
16.10.2020 22:59
Для мультипликационного фильма видеоряд с частотой 60 кадров в cекунду и звуковая восьмиканальная дорожка записываются отдельно. Для хранения на сервере видео преобразуют так, что...
BigRussionBosss
09.04.2020 16:48
заранее Гражданин 1 марта открыл счёт в банке, вложив 1000 рублей. Через каждый месяц размер вклада увеличивается на 2% от имеющейся суммы. Определить: Сумму вклада через один, два,...
aaaddd1988
09.04.2020 16:47
Записать внутреннее представление десятичных чисел: 28, -28....
win66123
09.04.2020 16:47
Введите, что будет выведено в результате выполнения следующего фрагмента программы: a := 15; b := 20; x := b; if a b then x := a-b else x := b-a; writeln (x);...
fgdh1waffeaf
18.12.2020 06:03
Информатика тема:Векторная графикаСоставьте программу для рисования домика если это возможно...
UraR1
18.12.2020 06:02
Очень информатика , таблица...
Помощниица1
18.12.2020 05:56
Для чего предназначен накопитель на жестком диске? 1. для обработки и хранения информации 2. для кратко-временного хранения информации 3. для долго-временного хранения информации...
Популярные вопросы
Всостав какого отдела позвоночника ящерицы входит ребра...
3
Определите в какой из пробирок с растворами находится каждая из солей: хлорид железа...
2
Определить работу выхода для лития, если красная граница фотоэффекта равна 0,52мкм...
2
Удобный для проведения генетических исследований объект?...
3
Каково значение битвы на косовом поле....
3
Записать слова в два столбика в зависимости от произношения: air, train, tail, airport,...
1
Одного города, салтыков-щедрин. 1. как вы думаете, почему писатель так издевается...
2
Информация о памятниках природы нижегородской области...
2
Предположим, что, когда фирма увеличивает применяемый капитал со 140 до 168 единиц,...
3
Реши уравнения : (287+x)-109=298 374+(x-129)=702...
3
begin
Square := abs((x2 - x1) * (y3 - y1) - (x3 - x1) * (y2 - y1)) / 2;
end;
var
x1, y1, x2, y2, x3, y3, s1, s2: real;
begin
write('Задайте первый треугольник(x1,y1,x2,y2,x3,y3): ');
readln(x1, y1, x2, y2, x3, y3);
s1 := Square(x1, y1, x2, y2, x3, y3);
write('Задайте второй треугольник(x1,y1,x2,y2,x3,y3): ');
readln(x1, y1, x2, y2, x3, y3);
s2 := Square(x1, y1, x2, y2, x3, y3);
if s1 > s2 then writeln('Площадь первого треугольника больше')
else if s1 < s2 then writeln('Площадь второго треугольника больше')
else writeln('Площади треугольников равны');
end.
p.s. проверять существуют ли такие треугольники не нужно, т.к. они уже заданы и нам нужно определить площадь большего.