C++, задача с массивом и разрядностью чисел
Вводится последовательность из N положительных целых чисел. Определить
разрядность каждого числа.
Написать программу на с++, желательно только со стандартными библиотеками.
Написать через for, while, do while (разными циклами)

natalia04062001 natalia04062001    3   28.02.2020 18:51    6

Ответы
avadnure avadnure  11.09.2020 19:39

#include <iostream>

#include <cstdlib>

using namespace std;

int main()

{

setlocale(LC_ALL,"russian");

cout << "Введите размер массива: ";

int N;

cin >> N;

N=N--;

unsigned int a[N];

for (int b = 0; b<=N; b++)

{

cout << "Введите число номер " << b << ": ";  

cin >> a[b];

}

for(int i=0; i<=N; i++)

{

if(a[i]<=255)

{

 cout << "Количество разрядов числа " << a[i] << " - 8" << endl;

}

if(a[i]>=256 && a[i]<=65535)

{

 cout << "Количество разрядов числа " << a[i] << " - 16" << endl;

}

if(a[i]>=65536 && a[i]<=4294967295)

{

 cout << "Количество разрядов числа " << a[i] << " - 32" << endl;

}

}

   system("pause");

   return 0;

}

Надеюсь, правильно понял определение разрядов.

Есть пожелания - в комментарии

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика