(c#) Напишите программу, которая запрашивает у пользователя числа до тех пор, пока каждое следующее число больше предыдущего. В конце программа сообщает, сколько чисел было введено. using System;

namespace z1
{
class Program
{
static void Main(string[] args)
{
Console.WriteLine("Введите начальное число");
int n = Convert.ToInt32(Console.ReadLine());
Console.WriteLine("Введите число");
int a = Convert.ToInt32(Console.ReadLine());
int k = 1;
while (true)
{
if (n < a)
{
k += 1;
n = a;
return;
}
Console.WriteLine("Введите число");
int b = Convert.ToInt32(Console.ReadLine());
}
Console.WriteLine($"кол-во чисел - {k}");
}
}
}
Почему код не работает?(50b)

nikrozumenko nikrozumenko    3   30.10.2021 04:43    6

Другие вопросы по теме Информатика