tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
C++. напишите программу, которая
C++. напишите программу, которая вводит номер месяца и выводит название времени года на языке. при вводе неверного номера месяца должно быть выведено слово 'no'.
kudgalina83
2 07.09.2019 01:10
3
Ответы
ВикаФан
06.10.2020 22:10
#include <iostream>
using namespace std;
int main()
{
cout << "Enter month num: " << endl;
unsigned month = 0;
cin >> month;
if (month <= 12 && month >= 1) {
switch (month / 3) {
case 1:
cout << "Spring" << endl;
break;
case 2:
cout << "Summer" << endl;
break;
case 3:
cout << "Autumn" << endl;
break;
default:
cout << "Winter" << endl;
break;
}
} else {
cout << "NO" << endl;
}
return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
GizziMix2007
06.10.2020 22:10
#include <iostream>
using namespace std;
int main(){
int x;
cin >> x;
if(x <= 0)
cout << "NO"
else if(x < 3)
cout << "Winter";
else if(x > 2 and x < 6)
cout << "Spring";
else if(x > 5 and x < 9)
cout << "Summer";
else if(x > 8 and x < 12)
cout << "Autumn";
else
cout << "NO;
return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
ania51
13.06.2019 01:20
Для хранения данных в компьютере служит: память процессор дисковод или монитор...
aksiniaplotniko
13.06.2019 01:20
Персональный компьютер не будет функционировать если: отключить дисковод,отключить оперативную память,отключить мышь или отключить принтер...
hihilaim
13.06.2019 01:20
Скорость передачи данных через adsl-соединение равна 64 000 бит/с. через данное соединение файл размером 125 килобайт. определите время передачи файла в секундах....
sasha1836
13.06.2019 01:20
Вкаком устройстве компьютера производится обработка информации? клавиатура,монитор,внешняя память,процессор....
nasamar
13.06.2019 01:20
Скакой целью люди кодируют информацию?...
veronikasabrin
13.06.2019 01:20
Определить может ли кирпич имеющий форму прямоугольного параллелепипеда с ребрами a,b,c пройти через круглое отверстие радиусом m...
lebedkova81
13.06.2019 01:20
Какое из устройств предназначено для ввода информации? процессор,принтер,клавиатура или память компьютера...
anastasiabobilevich
13.06.2019 01:20
Петя васечкин хочет выяснить, делится ли на 7 натуральное число, состоящее не более чем из 60 цифр. требуется написать программу, которая выполняет желание пети и находит...
Слива05
13.06.2019 01:20
Ребусрешите следующий числовой ребус: смех + гром = гремипри этом разным буквам соответствуют разные цифры.в ответе укажите через пробел цифры, которые соответствуют...
dmitrii66613
13.06.2019 01:30
№1 создать последовательность нажатия клавишей калькулятора (программу расчёта), найти значение выражения и записать результат: 23,7 * 3,9 + 71,25 / 2,3 – 78,9*0,8 =...
Популярные вопросы
Вычислите произведение удобным а) 36•25; б) 125•12; в) 75•24; г)...
2
Састное двух чисел равно 12.каким будет новое частное,если делитель...
3
Вкаком случае вес тела численно равен силе тяжести? не равен силе...
3
Верны ли следующие утверждения? а. свод правил поведения, регулирующих...
1
Complete the sentences .use your answers ( read the texts , ride...
2
Поставить правильно ударение в словах: пасти,показ,украинский,арбуз,маляр,дочка....
2
Длина первого отрезка 18 см а длина второго в 3 раза меньше .на сколько...
1
Составить сочинение на казахском ! тема: чем вреден фас-фут?...
1
Придумайте название сочинения на тему подвиг дедов-внукам наследие...
1
Ой пущу віночок на щастя на долю на милого вроду. це уривок із пісні...
2
using namespace std;
int main()
{
cout << "Enter month num: " << endl;
unsigned month = 0;
cin >> month;
if (month <= 12 && month >= 1) {
switch (month / 3) {
case 1:
cout << "Spring" << endl;
break;
case 2:
cout << "Summer" << endl;
break;
case 3:
cout << "Autumn" << endl;
break;
default:
cout << "Winter" << endl;
break;
}
} else {
cout << "NO" << endl;
}
return 0;
}
using namespace std;
int main(){
int x;
cin >> x;
if(x <= 0)
cout << "NO"
else if(x < 3)
cout << "Winter";
else if(x > 2 and x < 6)
cout << "Spring";
else if(x > 5 and x < 9)
cout << "Summer";
else if(x > 8 and x < 12)
cout << "Autumn";
else
cout << "NO;
return 0;
}