C#
Написать программу, в которой вводятся с клавиатуры предложения, и выводит на экран только цитаты, то есть предложения, заключенные в кавычки.

Terhiop Terhiop    2   01.06.2020 17:01    11

Ответы
Andreyp2881 Andreyp2881  15.10.2020 12:45

using System;

using System.Text.RegularExpressions;

namespace ConsoleApp1

{

   class Program

   {

       static void Main(string[] args)

       {

           string s;

           Console.WriteLine("Введите текст:");

           s = Console.ReadLine().Replace('\"','\'');

           Regex r = new Regex(@"'[^']+'");

           foreach (Match m in r.Matches(s))

               Console.WriteLine(m.Value);

       }

   }

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика