C++ или Pascal или C# Написать программу, которая запрашивает вещественное число a и, пользуясь только операцией умножения, вычисляет a28 за шесть операций

Raulikx Raulikx    2   11.06.2020 00:03    9

Ответы
Nina34732 Nina34732  15.10.2020 13:41

   class Program

   {

       static void Main(string[] args)

       {

           Console.WriteLine("[Введите число]\n");

           int a = Int32.Parse(Console.ReadLine());

           int a2 = a * a;

           int a4 = a2 * a2;

           int a8 = a4 * a4;

           int a16 = a8 * a8;

           int result = a16 * a8 * a4;

           Console.WriteLine("\nИсходное число: " + a + " \nЧисло в 2-й степени:" + a4 + " \nЧисло в 8-й степени: " + a8 + " \nЧисло в 16-й степени: " + a16 + " \nЧисло в 28-й степени: " + result + "");

       }

   }  

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика