C-free . напишите программу, которая вводит строку и выводит ее, сокращая каждый раз на 1 символ до тех пор, пока в строке не останется 1 символ.

denisskidan201 denisskidan201    2   22.11.2019 09:46    20

Ответы
XxШКОЛЬНИКxX XxШКОЛЬНИКxX  05.08.2020 10:53

#include <stdio.h>

#include <conio.h>

using namespace std;

int main()

{

char *Arr = new char[500];

printf("Entered string \n");

gets_s((char*)Arr, 500);

int count = 0;

for (int i = 0; Arr[i] != '\0'; i++)

{

 count++;

}

if (count == 1)

{

 return 0;

}

else

{

 for (int j = count; j>0; j--)

 {

  for (int k = 0; k < j; k++)

  {

   

   printf( "%c", Arr[k]);

  }

  printf("\n");

 }

}

delete[] Arr;

_getch();

return 0;

}

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика