C++ дан массив, состоящий из целых чисел. известно, что числа по неубыванию (то есть каждый следующий элемент не меньше предыдущего). напишите программу, которая определит количество различных чисел в этом массиве.

Победитель17 Победитель17    1   03.10.2019 00:50    12

Ответы
mahachkala1 mahachkala1  09.10.2020 12:52

// ConsoleApplication13.cpp: определяет точку входа для консольного приложения.

//

#include "stdafx.h"

#include <iostream>

using namespace std;

int main()

{

int a;

int b, c, col;

int d[100];

for (b = 1; b <= 100; b++) {

 d[b] = 0;

}

cin >> a;

bool f;

col = 0;

for (b = 1; b <= a; b++) {

 f = true;

 cin >> d[b];

 for (c = 1; c < b; c++) {

  if (d[b] == d[c]) {

   f = false;

  }

 }i

 f (f){ col++; }

 

}

cout << col;  

   return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика