C/c++ составить программу возведения натурального числа n в квадрат, учитывая такую закономерность: 1 ^ 2 = 1, 2 ^ 2 = 1 + 3, 3 ^ 2 = 1 + 3 + 5, 4 ^ 2 = 1 + 3 + 5 + 7, п ^ 2 = 1 + 3 + 5 + 7 + 9 + + 2n-1. не использовать операцию умножения!

Змей24 Змей24    2   29.09.2019 02:40    7

Ответы
Molderjkee Molderjkee  09.10.2020 01:51

#include <iostream>


using namespace std;


int main() {

long int i, number, square = 0;


jump:

cout << "Input a natural number: ";

cin >> number;

if (number <= 0) {

             cout << "Input error! Try again"<< endl;

             goto jump;

}


for(i = 1; i <= number; i++)

              square += i + i - 1;


cout << "The square of number " << number << " is " << square << endl;

return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика