Буду признателен. код на c++: написать программу, которая читает с клавиатуры строку символов, преобразует ее и выводит результат на дисплей. подсчитать количество слов в строке.

МашаСовельник МашаСовельник    1   14.07.2019 04:50    2

Ответы
bezimeni3 bezimeni3  15.09.2020 14:48
#include <iostream>
#include <sstream>
using namespace std;

 int main(){
   string str;
   getline(cin,str); //вводим поток в строку
   stringstream ss(str); //вводим строку в поток, при этом пробел делит слова на отдельные элементы
   int i(0); //счётчик
   while(ss>>str) //пока можно выводить элементы(слова)
    i++;
   cout << i;
   cin.get();
   cin.get();
   return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика