Будьте добры, напишите программу нахождения большего из трех чисел, используя процедуру (паскаль))

Гарфилд32 Гарфилд32    1   14.04.2019 20:03    1

Ответы
dasha00200100 dasha00200100  29.05.2020 11:57

Объяснение:

procedure Maximum(a, b, c:integer; var max:integer);

begin

 if ((a>=b) and (a>=c)) then begin

   max:=a;

   exit;

 end;

 if ((b>=a) and (b>=c)) then begin

   max:=b;

   exit;

 end;

 if ((c>=a) and (c>=b)) then begin

   max:=c;

   exit;

 end;

end;

var

 a1, b1, c1, max1:integer;

begin

 a1:=2; b1:=3; c1:=5;

 Maximum(a1, b1, c1, max);

 writeln(max);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика