Будте добры написать программу на паскале. условие: надо написать программу, которая решает квадратное уравнение. (используя goto)

katyamarkova22 katyamarkova22    3   14.09.2019 13:40    4

Ответы
marinamih marinamih  07.10.2020 14:21
var
a,b,c,x1,x2,d:real;
begin
write('Введите A='); readln(a);
write('Введите B='); readln(b);
write('Введите C='); readln(c);
D:=b*b-4*a*c;
if D<0 then begin
writeln('Нет корней');
end;
if D=0 then begin
writeln('x1=',-b/(2*a))
end;
if D>0 then begin
x1:=(-b-sqrt(d))/(2*a);
x2:=(-b+sqrt(d))/(2*a);
writeln('x1=',x1);
writeln('x2=',x2);
end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика