А)составьте программу, которая заполняет массив в[1..11] случайными целыми числами в диапазоне от -5 до 5 и преобразовывает его, заменяя элементы кратные 5 на 5,а остальные увеличивая в 5 раз. б)составьте программу, которая заполняет массив в[1..12] случайными целыми числами в диапазоне от 1 до 20 и определяет есть ли в массиве нечетные числа и выводит их на экран. в)заполните массив 8 произвольными целыми числами, введя их с клавиатуры и найдите среди них сумму и произведение положительных.

джем16 джем16    3   13.09.2019 16:20    14

Ответы
Den0410 Den0410  04.08.2020 07:23
Задача а
program a;var   i:integer;  a:array[-5..11] of integer; begin  randomize;  for i:=1 to 11 do begin    a[i]:=random(10)-5;    if a[i] mod 5 = 0 then a[i]:=5 else a[i]:=a[i]*5;    write (a[i],' ');    end;end.Задача б
program b;var   i:integer;  a:array[1..12] of integer; begin  randomize;  for i:=1 to 12 do begin    a[i]:=random(20);    if a[i] mod 2 = 1 then write (a[i],' ');    end;end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика