А)одномерный массив a заполнен десятью случайными целыми числами от 1 до 20. напишите программу вывода элементов массива в обратном порядке. б)напишите программу, которая массив из 20 элементов заполнит неповторяющимися целыми числами и выведет на экран элементы с нечетными индексами.

imoroz079 imoroz079    1   19.06.2019 16:20    2

Ответы
azz077 azz077  15.07.2020 20:48
А)
var
a:array[1..10]of integer;
i:integer;
begin
for i:=1 to 10 do
  a[i]:=random(20)+1;
for i:=10 downto 1 do
  write(a[i],' ');
end.
б)
var
a:array[1..20]of integer;
i:integer;
begin
for i:=1 to 20 do
  a[i]:=random(11*i)+10*i;
for i:=1 to 20 do
  if i mod 2=1 then write(a[i],' ');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика