tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
9по информатике паскаль 8 если
9по информатике паскаль 8 если сумма цифр трёхзначного числа чётная, то разделить на 2, если нет умножить на 2
VERIGINGUIGORY
1 25.09.2019 16:40
3
Ответы
trjg456isa
08.10.2020 18:56
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('n=');
if (n div 100+(n div 10) mod 10+n mod 10).IsEven then Writeln(n/2)
else Writeln(2*n)
end.
Пример
n= 319
638
ПОКАЗАТЬ ОТВЕТЫ
olegstar74p0a994
08.10.2020 18:56
Var
x, s: integer;
k: real ;
begin
readln(x);
if (x > 99) and (x < 1000) then
while x > 0 do
begin
s := s + x mod 10;
x := x div 10;
end;
k := s / 2;
if s mod 2 = 0 then
writeln(k)
else
writeln(s * 2);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
lenya013
17.04.2020 15:02
Начертить данную блок схему алгоритма в...
madinatrtyakov
17.04.2020 15:03
Постройте логическую схемуЗадание на фото...
Alex90111
17.04.2020 15:04
с задачей по информатике. Язык выполнения C++....
Maryan2609
17.04.2020 15:04
20 случайных чисел увеличить в два раза паскаль случайных чисел увеличить в два раза паскаль...
daryastasevich1
17.04.2020 15:04
Запиши доменное имя компьютера зарегистрированного в домене первого уровня de, второго уровня sky и имеющего собственное имя www....
den2424denoztwre
17.04.2020 14:45
Дана программа на языке Паскаль. Программа определения весовой категории в зависимости от веса спортсмена. Если вес спортсмена меньше 68, то «лёгкая категория» иначе...
ppetrovaa
17.04.2020 15:05
Паскаль Очень друзья, чему будет равен третий элемент вектора после выполнения следующего фрагмента программыx[1]:=0;for i:=2 to 3 dox[i]:=x[i-1]+2;...
nikitkasorokin2
17.04.2020 15:06
Заполнить массив квадратами натуральных чисел. Написать дополнительно метод подсчета среднего арифметического всех элементов массива ( с выводом значения на консоль )...
marimuravskap08uv0
17.04.2020 15:08
Напишите программу, которая в последовательности из 8-ми введенных с клавиатуры чисел определяет их сумму....
сартоваа
17.04.2020 15:09
Дан целочисленный массив из 1000 элементов. Элементы массива могут принимать неотрицательные целые значения до 10 000 включительно. Необходимо найти минимальный кратный...
Популярные вопросы
Довжина кола длина окружности вписоного в прямокутну трапецию доривнюэ...
3
[tex] \sqrt{16 \sqrt{x - 1 = 7} } [/tex]...
1
Как нарисовоть круг не отрывая ручки...
1
Озаглавьте текст. спишите, вставляя пропу-щенные буквы, раскрывая...
3
Кто знает латышский язык. работа с текстом. agnese un tumsas valdnieks...
1
Напишіть будь ласка есе за тезою : українська мова-це те, що я почув...
2
Купили 60 деревьев.причем яблонь было в 2 раа больше, чем груш. найдите...
1
найдите значение выражения 2,25- 5,25/ 2/9 + 5/18...
1
График в нескольких этапов у= одна вторая cos (x+п на 6) 25...
3
Назовите тела, изображённыена рисунках 2, 4. из каких веществ они...
1
Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('n=');
if (n div 100+(n div 10) mod 10+n mod 10).IsEven then Writeln(n/2)
else Writeln(2*n)
end.
Пример
n= 319
638
x, s: integer;
k: real ;
begin
readln(x);
if (x > 99) and (x < 1000) then
while x > 0 do
begin
s := s + x mod 10;
x := x div 10;
end;
k := s / 2;
if s mod 2 = 0 then
writeln(k)
else
writeln(s * 2);
end.