9класс фастом
написать программу, заполняющую массив 30 случайными числами [-10..80].
вывести массив.
определить в этом массиве сумму чисел, кратных 3
определить количество отрицательных чисел.
определить в этом массиве номер элемента, равного 0

07Лизочек07 07Лизочек07    1   24.10.2019 17:08    4

Ответы
Дурень228 Дурень228  10.10.2020 09:24

Var a: array [1..30] of integer;

sum3,otr,i,j:integer;

begin

randomize;

sum3:=0;

otr:=0;

for i:=1 to 30 do  

 begin

   a[i]:=random(91)-10;

   write(a[i]:4);

   if a[i] mod 3 = 0 then sum3:=sum3+a[i];

   if a[i]<0 then inc(otr);

 end;

 writeln;

 writeln('Sum: ',sum3,'   <0:',otr);

 for i:=1 to 30 do

   if a[i]=0 then  

     begin

      writeln('№',i,'=0');

     end;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика