(99 ! ) python напишите программу, которая находит в массиве минимальный и максимальный из чётных положительных элементов.если в массиве нет элементов с чётными положительными значениями,нужно вывести сообщение об этом.

vd89084999583 vd89084999583    2   20.09.2019 16:20    35

Ответы
dzorina2002 dzorina2002  21.08.2020 12:28
mas = [int(i) for i in input('Введите массив : ').split()]
flag = 0
for i in mas:
    if i%2 == 0:
        max = min = i
        flag = 1
        break
if flag == 0:
    print('Четных нет!')
    exit()
for i in mas:
    if i%2 == 0 and i > max:
        max = i
    if i%2 == 0 and i < min:
        min = i
print(max,min) 
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика