№9. Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения. Учтите, что числа могут быть отрицательными.
Входные данные
Входная строка содержит два целых числа.
Выходные данные
Программа должна вывести произведение введённых чисел

Saharok00711 Saharok00711    2   16.07.2021 17:38    18

Ответы
kristinakalash kristinakalash  15.08.2021 18:20

1 Вариант:

numbers=list(map(int,input().split()))

if numbers[0] == 0 or numbers[1] == 0:

   print(0)

else:

   print(numbers[0]/(1/numbers[1]))

2 Вариант:

numbers=list(map(int,input().split()))

summ=0

if numbers[1]<0 and numbers[0]<0:

   for i in range(-numbers[0]):

       summ+=-numbers[1]

elif numbers[1]<0:

   for i in range(numbers[0]):

       summ+=numbers[1]

else:

   for i in range(numbers[1]):

       summ+=numbers[0]

print(summ)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика