7класс. turbo pascale №1: int(-5,89) int(0,53) round(-5,8) round(5,2) frac(-17,4) frac(0,32) trunc(-17,4) trunc(15,2) 45 div 4 15 mod 8 (489 div 10) mod 10 №2: определите значение переменной a. определите значение переменной a в результате выполнения фрагмента программы для начальных значений a, b. if a+b> 5 then a: =a-b else a: =a*b; а=1, в=2; а=3, в=3; а=4, в=2; а=-3, в=5 №3: составьте программу. составьте программу, определяющую, кто из двух подруг старше маша или саша, или они ровесники. m – возраст маши s – возраст саши (исходные переменные) результат – выведенное на экран предложение: саша старше маши (если s> m) маша старше саши (если m> s) саша и маша ровесники (если m=s) №4: компьютер запрашивает число. если число положительное, то делит его на 7, в обратном случае возводит его в квадрат. №5: найти наибольшее число издвух чисел. №6: найти наибольшее число из трёх чисел. №7: найти наибольшее число из четырёх чисел. №8: узнать, что произойдёт с ракетой. в три варианта ответа - 1) ракета станет спутником земли, 2) ракета станет спутником солнца, 3) ракета покинет солнечную систему. если в ответе получится число меньше 7.9, то нужно написать begin, если в ответе получится число равно или больше 7.9, но меньше 11.2, то ракета станет спутником земли, если в ответе получится число равное или больше 11.2, но меньше 16.6, то ракета станет спутником солнца, если в ответе получится число равное или больше 16.6, то ракета покинет солнечную систему. первая космическая скорость (7,9 км/с) – спутник земли. вторая космическая скорость (11.2 км/c) – спутник солнца. третья космическая скорость (16.6 км/с) – покидает солнечную систему.

Крути228 Крути228    1   21.05.2019 09:10    4

Ответы
RageTeenage RageTeenage  15.06.2020 10:17

Задание №1:
int(-5,89)= -5
int(0,53)=0
round(-5,8)=-6
round(5,2)=5
frac(-17,4)=0,4
frac(0,32)=0,32
trunc(-17,4)=-17
trunc(15,2)=15
45 div 4=11
15 mod 8=7
(489 div 10) mod 10=8

Задача №2:

а=1, в=2;     a=2

а=3, в=3;    a=0

а=4, в=2;    a=2

а=-3, в=5    a=-15

Задача №3:

var m,s:integer;
begin
readln(m);
readln(s);
if s>m then writeln('Саша старше Маши')
        else if m>s then writeln('Маша старше Саши ')
              else writeln('Саша и Маша ровесники');
end.

Задача №4:

var a:real;
begin
write('Введите число: ');
readln(a);
if a>0 then a:=a/7
        else a:=a*a;
writeln(a);
end.

Задача №5:

var a,b:real;
begin
write('Введите первое число: ');
readln(a);
write('Введите второе число: ');
readln(b);
if a>b then writeln('Наибольшее число: ',a)
        else writeln('Наибольшее число: ',b);
end.

Задача №6:

var a,b,c,p:real;
begin
write('Введите первое число: ');
readln(a);
write('Введите второе число: ');
readln(b);
write('Введите третье число: ');
readln(c);
if a>b then if a>c then p:=a
                    else p:=c
       else if b>c then p:=b
                    else p:=c;
writeln('Наибольшее число: ',p);
end.

Задача №7:

var a,b,c,d,p:real;
begin
write('Введите первое число: ');
readln(a);
write('Введите второе число: ');
readln(b);
write('Введите третье число: ');
readln(c);
write('Введите четвертое число: ');
readln(d);
if a>b then if a>c then p:=a
                    else p:=c
       else if b>c then p:=b
                    else p:=c;
if p<d then p:=d;
writeln('Наибольшее число: ',p);
end.

Задача №8:

var a:real;
begin
a:=0;
while a<7.9 do
begin
  write('Введите скорость ракеты: ');
  readln(a);
  if (a>=7.9) and (a<11.2) then writeln('Ракета станет спутником Земли')
    else if (a>=11.2) and (a<16.6) then writeln('Ракета станет спутником Cолнца')
          else if a>=16.6 then writeln('Ракета покинет Cолнечную систему')
                          else writeln('Требуется повторный ввод скорости');
end;
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика