7. На вход программе подается натуральное число. Каких цифр в числе больше четных или нечетных. В ответ выведите 1, если больше нечетных и 0, если четных и 2, если их количество одинаково.Питон

ZakAnyta ZakAnyta    3   21.04.2020 14:50    3

Ответы
Зл0йстудент Зл0йстудент  13.10.2020 14:35

num = input()

n = len(num)

odd = 0

noodd = 0

while i < len(num):

   if(int(num[i]) % 2 == 0):

       odd = odd + 1

   else :

       noodd = noodd + 1

if(odd == noodd):

   print(2)

elif(odd > noodd):

   print(0)

else :

   print(1)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика