7.4. описать массив из тридцати записей—точек на плоско- сти. заполнить его случайно выбранными координатами—числами в диапазоне от −10 до 100. написать функцию, которая получает две точки и возвращает расстояние между этими точками. используя написанную функцию определить, какая из точек находится на наибольшем расстоянии от начала координат. вывести на экран номер точки в массиве и ее координаты. если решений несколько, вывести все. написать программу не пойму как сделать.

Екатерина3817 Екатерина3817    2   15.06.2019 19:00    4

Ответы
faraon21 faraon21  12.07.2020 20:27
Var
 K:array[1..2,1..13]  of integer;
 i,j,ind,x,y:integer;
 MAX:real;
 function RAST(x1,x2,y1,y2:integer):real;
  begin
   RAST:=sqrt(sqr(x2-x1)+sqr(y2-y1));
  end;
begin
 MAX:=-2*sqr(-10-1);
 randomize;
 writeln('Исходные точки:');
 for j:=1 to 13 do
  begin
    writeln('Точка № ',j,', с координатами(X,Y)');
    for i:=1 to 2 do 
      begin
        K[i,j]:=random(110) - 10;
        write(K[i,j],'  ');
      end;
    writeln;
   end;
 for i:=1 to 13 do
   if RAST(0,K[1,i],0,K[2,i])>MAX
    then
      begin
         MAX:=RAST(0,K[1,i],0,K[2,i]);
         x:=K[1,i];
         y:=K[2,i];
         ind:=i;
      end;
writeln('Номер точки: ',ind,'  Координаты: ',x,' ; ',y);
end.
  
   

7.4. описать массив из тридцати записей—точек на плоско- сти. заполнить его случайно выбранными коор
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика