tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
6. вычислить суммы элементов,
6. вычислить суммы элементов, для массивов х(10), y(20), z(25).
yegor655
1 23.07.2019 12:50
6
Ответы
hhhhyd
07.08.2020 13:14
/* gnu gcc */
#include <iostream>
#include <cstdlib>
using namespace std;
int main()
{
int x[10];
int y[20];
int z[25];
int xs=0, ys=0, zs=0;
// Заполняем массивы случайными числами до 100
srand(time(0));
cout <<"Массив X(10):" <<endl;
for(int i=0; i<10; ++i)
{
x[i] = rand() % 100;
cout <<x[i] <<" ";
}
cout <<endl;
cout <<"Массив Y(20):" <<endl;
for(int i=0; i<20; ++i)
{
y[i] = rand() % 100;
cout <<y[i] <<" ";
}
cout <<endl;
cout <<"Массив Z(25):" <<endl;
for(int i=0; i<25; ++i)
{
z[i] = rand() % 100;
cout <<z[i] <<" ";
}
cout <<endl;
// Считаем суммы элементов массивов
for(int i=0; i<10; ++i)
xs+=x[i];
for(int i=0; i<20; ++i)
ys+=y[i];
for(int i=0; i<25; ++i)
zs+=z[i];
cout <<endl;
// Выводим суммы элементов на экран
cout <<"Сумма элементов массива X(10) = " <<xs <<endl;
cout <<"Сумма элементов массива Y(20) = " <<ys <<endl;
cout <<"Сумма элементов массива Z(25) = " <<zs <<endl;
return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
HardFunny
24.05.2020 15:56
Исполнитель Чертёжник перемещается на координатной плоскости, оставляя след в виде линии. Чертёжник может выполнять команду сместиться на (а, b), где а, b – целые числа....
Белялова
24.05.2020 15:56
решить. (Часть решить. (Часть 1) >...
alinamazur003
25.05.2020 15:45
Дан массив, состоящий из 8 целых чисел. Составить программу, вычисляющую сумму нечётных элементов массива....
9989744524081
15.12.2020 09:41
В программировании можно из одной функции вызывать другую. Для иллюстрации этой возможности напишите программу по следующему описанию. Основная ветка программы, не считая...
Gdyxtk
15.12.2020 09:41
4. Дана таблица пропуска уроков учениками за неделю. а)Напишите в ячейке D8 функцию для выявления количества учеников, пропустивших уроки во вторник. б)Напишите в ячейке...
tanusik32
10.09.2019 11:40
Переведите двоичное число 100100101 в систему счисления с основанием 11...
kolisnyk98
24.08.2019 14:30
В! дано целое число n и массив из n вещественных чисел. найти сумму и произведение чисел, расположенных на нечетных местах в данном массиве....
87752465940
12.12.2021 14:49
Как вы понимаете смысл высказывания средства борьбы со злом иногда бывает хуже чем само зло...
Gggg25632
12.12.2021 14:49
Даны середины сторон треугольника АВС : Р (1; 2) – середина АВ, Q (5; 1) – середина ВС. Найти точку пересечения высоты СF и медианы АК с решением....
alechka7
12.12.2021 14:49
Начертите две пересекающиеся прямые и выберите на одной из них отрезок, не имеющий общих точек с другой прямой. Укажите точку, которая одновременно принадлежит двум прямым....
Популярные вопросы
Надо составить 10 предложений в past simple. вопрос в : what did you...
1
Восстание степана разина,основные события(кратко, только даты и что...
1
Данные слова поставить в родительный дательный предложный падежах пустыня...
2
Сергей вышел из дома и направился к другу .когда он отошёл от дома...
2
Тиорема виета. составь квадратное уравнение, корнями которого являются...
2
Найдите значение выражение при б=-1.2 4.3б-(7.8б-3)-4.1=...
1
Что такое сравнение? найди его в тексте старик лодожкин...
2
Фигура ангела, установленная на шпиле петиопавловского собора в 1778...
3
Индтвидуальный профессиональный карьерный рост...
2
Впалату 84кг гречневой крупы и 91кг риса крупа каждого вида была расфасована...
2
#include <iostream>
#include <cstdlib>
using namespace std;
int main()
{
int x[10];
int y[20];
int z[25];
int xs=0, ys=0, zs=0;
// Заполняем массивы случайными числами до 100
srand(time(0));
cout <<"Массив X(10):" <<endl;
for(int i=0; i<10; ++i)
{
x[i] = rand() % 100;
cout <<x[i] <<" ";
}
cout <<endl;
cout <<"Массив Y(20):" <<endl;
for(int i=0; i<20; ++i)
{
y[i] = rand() % 100;
cout <<y[i] <<" ";
}
cout <<endl;
cout <<"Массив Z(25):" <<endl;
for(int i=0; i<25; ++i)
{
z[i] = rand() % 100;
cout <<z[i] <<" ";
}
cout <<endl;
// Считаем суммы элементов массивов
for(int i=0; i<10; ++i)
xs+=x[i];
for(int i=0; i<20; ++i)
ys+=y[i];
for(int i=0; i<25; ++i)
zs+=z[i];
cout <<endl;
// Выводим суммы элементов на экран
cout <<"Сумма элементов массива X(10) = " <<xs <<endl;
cout <<"Сумма элементов массива Y(20) = " <<ys <<endl;
cout <<"Сумма элементов массива Z(25) = " <<zs <<endl;
return 0;
}