6. написать программу тремя с циклами «до», «пока» и с параметром ). : ввести n чисел. найти сумму четных из них. проанализируйте решения. какое проще и почему?

Кукамука Кукамука    2   21.05.2019 16:50    2

Ответы
Androidekstas Androidekstas  16.06.2020 11:59

uses crt;

var s,n,ch:integer;

begin

for i:=1 to n do

begin

if ch mod 2 = 0 then

s:=s+ch;

end;

end.

 

uses crt;

var s,n,ch,i:integer;

begin i:=1;

while i <=n do

begin

if ch mod 2 = 0 then

s:=s+ch; inc(i);

end;

end.

 

 

uses crt;
var s,n,ch,i:integer;
begin i:=1;
n:=5;
repeat
begin
readln(ch);
if ch mod 2 = 0 then
s:=s+ch; inc(i);
end;
until i>=n;

writeln(s);
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика