50 ! напишите программу. в первой строке вводится натуральное чило n вывести на экран - произведение нечетных цифр числа (считается, что хотя бы одна нечетная цифра в числе имеется) на c++

Маминбандит138 Маминбандит138    3   22.08.2019 04:00    4

Ответы
ScourgeTheCat ScourgeTheCat  26.08.2020 08:17
#include <iostream>
using namespace std;

int main() { 
   int n,k=1,m,p=0;
   cout<<"n = ";  cin>>n;
   while (n>0) {
     m=n%10;
     if (m%2==1) { k*=m; p=1; }
     n=n/10;
   }
   if (p>0) cout<<"result: "<<k;
   else cout<<"no odd digits";
   cout<<endl;

   system("pause");
   return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика