50 .напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 13. программа получает на вход количество чисел в последовательности, а затем сами числа. в последовательности всегда имеется число, кратное 13. количество чисел не превышает 1000. введённые числа не превышают 30 000. программа должна вывести одно число - минимальное число, кратное 13. входные данные 3, 130, 25, 169. выходные данные 130. (чтобы её можно было запустить в паскаль) ​

Tomiriszharasbaeva Tomiriszharasbaeva    3   18.05.2019 16:06    6

Ответы
Mercedess65amg Mercedess65amg  11.06.2020 22:54

Var i,c,count,min:integer;

Begin

Read (count);

Min:=30000;

For i:=1 to count do

Begin

Read(c);

If c < min and c mod 13 = 0 then

Min:= c;

End;

Write(min);

End.

ПОКАЗАТЬ ОТВЕТЫ
newagain newagain  11.06.2020 22:54

#include <iostream>

using namespace std;

int main()

{

   int b,c,d,e,f,g;

   cin >>b;

   d=30001;

   int A[b];

   for ( int i=0;b>i;i++ )

   {

       cin >> A[i];

   }

       for ( int i=0;b>i;i++ )

   {

       if ( A[i]%13 ==0 )

       {

           if ( A[i]< d )

           {

               d=A[i];

           }

       }

   }

   cout << d;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика