50 ! написать программу которая просит ввести 10 чисел и находит сумму всех чисел,которые больше 0 из ряда введенных для pascal abc

sashasas12365 sashasas12365    1   16.09.2019 13:20    3

Ответы
Nikita45Nikita45 Nikita45Nikita45  07.10.2020 19:47
Program abc;
var a, summa:integer;
begin
summa:=0;
writeln('Введите 10 чисел');
for i:integer:=1 to 10 do begin
 readln(a);
if a>0 then summa:=summa+a;
end;
writeln(summa)
end.
ПОКАЗАТЬ ОТВЕТЫ
liona676 liona676  07.10.2020 19:47
// PascalABC.NET 3.3, сборка 1576 от 16.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
var a:= ReadArrInteger(10);
Writeln(a.Where(t->t>0).Sum);
end.
Пример:
0
12
2
3
5
6
1
2
5
6
42
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика