5.Программа получает на вход натуральное число N (3 ≤ N ≤100, N - нечетное). Выведите на экран таблицу размером NxN, средний столбец и средняя строка которой заполнены единицами, все остальные элементы нули.Язык Питон подалуйста​

У4КГРВ У4КГРВ    3   18.05.2020 21:23    8

Ответы
egorbelov06 egorbelov06  14.10.2020 23:20

n = int(input())

a = [['0'] * n for i in range(n)]

for i in range(n):

    for j in range (n):

         a[i][n//2] = '1'

         a[n//2][j] = '1'

for l in a:

    print(*l)  

Объяснение:

С цикла for сначала закрашивается вертикаль, потом горизонталь

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика