5. Напишите программу, которая заполняет массив из 10 элементов случайными числами на отрезке
[-2; 2] и находит произведение ненулевых элементов ​

ketgalyschko ketgalyschko    2   01.03.2020 09:43    28

Ответы
princessa2016 princessa2016  11.10.2020 15:47

C# 8.0:

using System;

using System.Linq;

...

var Arr = RandomIntArr(-2,2,10);

Console.WriteLine(Arr.Where(x=>x!=0).Aggregate((x,y)=>x*y));

...

static int[] RandomIntArr(int Min, int Max, int ArrLen) {

   Random rnd = new Random();

   int[] Out = new int[ArrLen];

   for (int i = 0; i < ArrLen; i++)  Out[i] = rnd.Next(Min, Max+1);

   return Out;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика