5. дан двумерный массив целых чисел. составить программу, которая определяет, есть ли в некотором столбце массива хотя бы один элемент, кратный заданному числу.

megachiglakov megachiglakov    3   02.10.2019 17:40    4

Ответы
lhukotunl lhukotunl  09.10.2020 12:12
PascalABC.NET 3.4.2, сборка 1884 от 24.11.2018Внимание! Если программа не работает, обновите версию!

begin

 var (m, n) := ReadInteger2('Количество строк и столбцов в массиве:');

 Writeln('*** Исходный массив ***');

 var a := MatrRandom(m, n, -99, 99);

 a.Println(4);

 Writeln(4 * a.ColCount * '-');

 var nCol := ReadInteger('В каком столбце ищем?');

 var C := ReadInteger('На кратность чему проверить?');

 if a.Col(nCol - 1).Any(t -> t mod C = 0) then

   Writeln('Есть такие элементы')

 else Writeln('Таких элементов нет')

end.


5. дан двумерный массив целых чисел. составить программу, которая определяет, есть ли в некотором ст
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика