4а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами удваиваются , а элементы с нечетными индексами утраивает.выведите на экран исходный и полученный массив. б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .выведите на экран исходный и полученный массивы. 5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями. 6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами. б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , строго по возрастанию. напишите хоть какое нибудь нужно к завтрому

милка328 милка328    1   29.05.2019 00:40    8

Ответы
vorske vorske  26.06.2020 20:42
4 а)
const n=10;
var a:array[1..n] of integer; i,k:integer;
begin
writeln('Исходный массив: ');
for i:=1 to n do begin
a[i]:=random(10);
write(' ',a[i]);
end;
writeln;
for i:=1 to n do begin
if ((i mod 2) = 0) then
a[i]:=a[i]*2
else
a[i]:=a[i]*3;
end;
writeln('Конечный массив: ');
for i:=1 to n do 
write(' ',a[i]);
end.
б)
const n=10;
var a:array[1..n] of integer; i,k:integer;
begin
writeln('Исходный массив: ');
for i:=1 to n do begin
a[i]:=random(10);
write(' ',a[i]);
end;
writeln;
for i:=1 to n do begin
if ((i mod 2) = 0) then
a[i]:=a[i]-a[i]*2;
end;
writeln('Конечный массив: ');
for i:=1 to n do 
write(' ',a[i]);
end.
5 a)
const n=10;
var a:array[1..n] of integer; i,k:integer;
begin
k:=0;
writeln('Исходный массив: ');
for i:=1 to n do begin
a[i]:=random(10);
write(' ',a[i]);
end;
writeln;
for i:=1 to n do begin
if (i>2) and (a[i]>a[i-1]) then
k:=k+1;
end;
writeln('Конечный массив: ');
for i:=1 to n do
 write(' ',a[i]);
writeln;
write('Кол-во элементов больших соседа слева ',k);
end.
5 б)
const n=10;
var a:array[1..n] of integer; z,i,k:integer;
begin
k:=0;
z:=0;
writeln('Исходный массив: ');
for i:=1 to n do begin
a[i]:=random(10);
write(' ',a[i]);
end;
writeln;
for i:=1 to n do begin
if ((i mod 2) = 0) then
k:=k+1;
if k=2 then
 begin 
k:=0;
z:=z+1;
end;
end;
writeln('Конечный массив: ');
for i:=1 to n do 
write(' ',a[i]);
writeln;
write('Кол-во четных пар: ',z);
end.
6 а)
const n=10;
var a:array[1..n] of integer; s,k,i:integer;
sr:real;
begin
s:=0;
k:=0;
writeln('Исходный массив: ');
for i:=1 to n do begin
a[i]:=random(10);
write(' ',a[i]);
end;
writeln;
for i:=1 to n do begin
if ((a[i] mod 2) = 0) and ((i mod 2) <> 0) then
begin
s:=s+a[i];
k:=k+1;
end;
end;
sr:=s/k;
writeln('Конечный массив: ');
for i:=1 to n do 
write(' ',a[i]);
writeln;
write('Среднее арифметическое четных элементов с нечетными индексами: ',sr);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика