46. составить программу, которая проверяла бы, не приводит ли суммирование двух целых чисел а и в к переполнению (т.е. к результату большему чем 32 767). если будет переполнение, то сообщить об этом, иначе вывести сумму этих чисел. через дельфи

dank02 dank02    2   01.07.2019 08:50    11

Ответы
BazikPro BazikPro  02.10.2020 17:14
Program Name;
uses crt;
Var
a, b, s :integer;
Begin
Write('введите a ');
readln(a);
Write('введите b ');
readln(b);
S:=a+b;
if s<32767 then
writeln(s)
else
writeln('произошло переполнение');
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика