45 . составить программу, которая выводит на экран сумму, произведение и среднее арифметическое кубов всех целых чисел от a до b. (значение переменных a и b вводятся с клавиатуры).

busiginaev2015 busiginaev2015    2   13.09.2019 00:30    5

Ответы
мериэмс мериэмс  07.10.2020 10:46
program sdad; var a, b, i, c: integer; sum, pro, sr: real; begin sum := 0; pro := 1; sr := 0; c := 0; readln(a, b); for i := a to b do begin c := c + 1; sum := sum + i; pro := pro * i; sr := sr + i * i; end; sr := sr / c; writeln('Сумма чисел = ', sum); writeln('Произведение чисел = ', pro); writeln('Среднее арифметическое кубов = ', sr); end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика