40 напишите программу в паскале с оператором repeatдано целое число n (> 0) используя операции деления нацело и взятия остатка от деления, найти количество и сумму его цифр (n=63)

SharkiLoge SharkiLoge    2   16.05.2019 17:44    5

Ответы
helpmeplease24 helpmeplease24  10.06.2020 13:11

program raf105;

var abc,a,sum,count: integer;

begin

write('Введите число: ');

readln(abc);

count:= -1;

repeat

 a:= abc mod 10;

 sum:= sum+a;

 count:= count+1;

 abc:= abc div 10;

until a=0;

writeln('Сумма цифр: ',sum);

writeln('Количество цифр: ',count);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика