4. напишите программу, определяющую, верно ли, что при деление целого отрицательного числа а на целое положительное число b получается заданный остаток r или s. 5. напшите программу, при выполнение которой выводится 1, если заданное число х принадлежит отрезку (a; b), или 0 в противном случае

Lunitoes Lunitoes    2   05.06.2019 10:30    4

Ответы
aruukewa123 aruukewa123  05.07.2020 22:42
1.
var a,b,r,s:integer;
begin
write('Введите числа a и b: ');
readln(a,b);
write('Введите остатки r и s: ');
readln(r,s);
if (a mod b=r) or (a mod b=s) then writeln('Да, верно')
  else writeln('Нет, неверно')
end.

2.
var a,b,x:real;
begin
write('Введите числа a и b: ');
readln(a,b);
write('Введите x: ');
readln(x);
if (a<=x) and (x<=b) then writeln(1)
  else writeln(0)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика