tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
4. массив а размером 10 заполняется
4. массив а размером 10 заполняется по формуле i-4, где i- счётчик индексов. поменять местами второй и предпоследний элементы массива. ( в паскале)
Azilll
3 20.08.2019 06:30
5
Ответы
elenareznik201
05.10.2020 06:46
Var
a: array[1..10] of integer;
i: integer;
begin
for i:=1 to 10 do
a[i] := i-4;
a[2] := a[9] + a[2];
a[9] := a[2] - a[9];
a[2] := a[2] - a[9];
for i:=1 to 10 do
write(a[i], ' ');
end.
ПОКАЗАТЬ ОТВЕТЫ
vasipovismail
05.10.2020 06:46
// PascalABC.NET 3.2, сборка 1379 от 21.01.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrGen(10,i->i-4,1); a.Println;
Swap(a[1],a[8]); a.Println
end.
Результаты
-3 -2 -1 0 1 2 3 4 5 6
-3 5 -1 0 1 2 3 4 -2 6
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
EpicCross
07.06.2019 01:30
Turbo pascal var i,n: integer; begin writeln( vvedite n ); readln(n); for i: =1 to n do if (i mod 2 0)and(i mod 3 0)and(i mod 5 0)then writeln(i); readln end. данная...
Leonid02super
07.06.2019 01:30
Дано четырехзначное число найти произведение его цифр...
NaStYтуут
07.06.2019 01:30
Исполнитель кузнечик живёт на числовой оси. кузнечик умеет выполнять команды: вперёд n (кузнечик прыгает вперёд на n единиц), назад м (кузнечик прыгает назад на м...
kastalia2017
04.12.2019 05:10
Второй вариант .дано натуральное число найти max нечестную цифру.х=8354...
Наполнение
04.12.2019 05:17
Напишите программу которая запрашивает у пользователя координаты точки и затем рисует квадрат размером 10х10,где вселенная точка является координатор левого верхнего...
zanunkyk
04.12.2019 21:54
Напишите наименьшее целое число х, для которого истинно высказывание: не (х 9 и не (х нечетное) сс по инфе...
AlinaZimina1
04.12.2019 21:53
Данных в электронной таблице-это записей по значениям одного из полей...
Sanchos106
04.12.2019 21:52
Для какого из указанных значений числа x истинно выражение (x 3) и ((х 2) или (х !...
Khlana30
04.12.2019 21:50
Нужна по формулам в excel фото тут (p.s нужно сделать 4 , в том плане что формулы вписать)...
timofeyfrol
30.05.2023 04:24
Знайди значення змінної А після виконання циклу А)2 Б)3 В)10...
Популярные вопросы
Кто такой капиталист - предприниматель и наемный работник?...
1
1. как найти период синусоиды? не понял, как это делать. 2. как...
3
Вдетском мире продавали двухколесные и трехколесные самокаты....
3
Город с наибольшим среднегодовым количеством осадков (по россии)...
1
Теплоход при столкновении с лодкой может потопить её без каких-либо...
1
Хозяйка засолила в 6 оинаковых банках 18 кг огурцов . сколько...
3
Определите страну по ее краткому описанию. страна расположена...
3
Положительное сальдо торгового это хорошо или плохо...
1
Какой из рядов записан в порядке роста (be mg ca sr) (s p si al)(...
2
Одне из чисел у 7 разив менше вид иншого знайдить ци числа якщо...
2
a: array[1..10] of integer;
i: integer;
begin
for i:=1 to 10 do
a[i] := i-4;
a[2] := a[9] + a[2];
a[9] := a[2] - a[9];
a[2] := a[2] - a[9];
for i:=1 to 10 do
write(a[i], ' ');
end.
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrGen(10,i->i-4,1); a.Println;
Swap(a[1],a[8]); a.Println
end.
Результаты
-3 -2 -1 0 1 2 3 4 5 6
-3 5 -1 0 1 2 3 4 -2 6