37 ! составить программу на pascal.

условие: даны три стороны треугольника. вычислите площадь и периметр.
ход решения: ввести три цифры - стороны треугольника и с форум нахождения площади и периметра треугольника найти их.

rf2048111111ozt4z7 rf2048111111ozt4z7    1   17.12.2019 15:22    6

Ответы
Школяяяра Школяяяра  10.10.2020 21:14

var a,b,c,p,s: real;

begin

 write('Введите 1-ю сторону: '); readln(a);

 write('Введите 2-ю сторону: '); readln(b);

 write('Введите 3-ю сторону: '); readln(c);

 p:= a + b + c;

 s:=sqrt((p/2)*(p/2-a)*(p/2-b)*(p/2-c));

 writeln('Периметр = ', p);

 writeln('Площадь = ', s);

end.

ПОКАЗАТЬ ОТВЕТЫ
MAKCUMKA228 MAKCUMKA228  10.10.2020 21:14

===== PascalABC.NET =====

begin

 var (a, b, c) := ReadReal3('Введите длины сторон через пробел:');

 var P := a + b + c;

 var p2 := P / 2;  // полупериметр

 var S := Sqrt(p2 * (p2 - a) * (p2 - b) * (p2 - c)); // ф-ла Герона

 Println('P =', P, '   S =', S)

end.


37 ! составить программу на pascal. условие: даны три стороны треугольника. вычислите площадь и пери
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика