35 за по ! имеется символьный двумерный массив m(6x6), у которого индексация строк и столбцов начинается с 0. целочисленная переменная count_ изначально равна нулю. код функции find_p() написан на языке c++. чему будет равно значение переменной count_ после вызова функции с параметрами (0, 0), то есть find_p(0, 0)? массив: s . . # # # . # . . . # . # . # # # . # . . # # # # # . f код функции: find_p(int x, int y) { if (x < 0 || x > 5 || y < 0 || y > 5) return 0; if (m[y] [x] == 'f') return 1; if (m[y] [x] ! = '.' & & m[y] [x] ! = 's') return 0; m[y] [x] = '+'; count_++; if (find_p (x, y - 1)) return 1; if (find_p (x + 1, y)) return 1; if (find_p (x, y + 1)) return 1; if (find_p (x - 1, y)) return 1; m[y] [x] = 'x'; return 0; }

sooooooos1 sooooooos1    2   12.09.2019 09:20    4

Ответы
Секретик321321 Секретик321321  07.10.2020 09:21
ответ:  17

// delete.cpp: определяет точку входа для консольного приложения.//
#include "stdafx.h"#include "iostream"#include <conio.h>
using namespace std;
int count_ = 0;
char m[6][6] = { {'S', '.', '.', '.', '#', '#'}, { '#', '.', '#', '.', '.', '.' }, { '.', '.', '#', '.', '.', '#' }, { '.', '.', '#', '#', '#', '.' }, { '#', '.', '.', '.', '#', '#' }, { '#', '#', '#', '.', '.', 'F' }};
int find_p(int x, int y) { if (x < 0 || x > 5 || y < 0 || y > 5) return 0; if (m[y][x] == 'F') return 1; if (m[y][x] != '.' && m[y][x] != 'S') return 0; m[y][x] = '+'; count_++; if (find_p(x, y - 1)) return 1; if (find_p(x + 1, y)) return 1; if (find_p(x, y + 1)) return 1; if (find_p(x - 1, y)) return 1; m[y][x] = 'x'; return 0;}

int main(){ find_p(0, 0); cout << count_; //вывод _getch(); // задержка    return 0;}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика