35 !
ниже записана программа. получив на вход число , эта программа печатает два числа, и . укажите максимальное и минимальное числа, при вводе которых алгоритм печатает сначала 3, а потом 7.
цел x, l, m
ввод x
l: =0; m: =0
нц пока x > 0
l: = l + 1
если mod(x,2) = 1 то
m: = m + div(mod(x,10),2)
все
x: = div(x,10)
кц
вывод l, нс
вывод m, нс
var x, l, m: integer;
begin
readln(x);
l: =0; m: =0;
while x > 0 do begin
l: = l + 1;
if x mod 2 = 1 then
m: = m +
(x mod 10) div 2;
x: = x div 10;
end;
writeln(l); write(m);
end.

egordyachenko egordyachenko    2   26.09.2019 11:18    8

Другие вопросы по теме Информатика