30 ! составьте программу ,которая формирует массив ,содержащий 8 случайных целых чисел, принадлежащих промежутку [0; 5] ,и преобразует элементы массива по следующему правилу: чётное число умножает на 5 ,а от нечётного отнимает 2.

masaberegovenko masaberegovenko    3   29.05.2019 02:40    10

Ответы
аноним4378 аноним4378  27.06.2020 01:44
Var
a:array[1..8] of integer;
i:integer;
begin
randomize;
for i:=1 to 8 do
begin 
a[i]:=random(6); 
  if a[i] mod 2 = 0 then a[i]:=a[i]*5
  else a[i]:=a[i]-2;
  write(a[i],' ');
 end;
end.

Надеюсь на "Лучший ответ"
ПОКАЗАТЬ ОТВЕТЫ
alekseislepsov2008 alekseislepsov2008  27.06.2020 01:44
Uses crt;
var a:array[1..8] of integer;
    x:integer;
begin
     randomize;
     for x:=1 to 8 do
     begin
          a[x]:=random(6);
          writeln('a[',x,']:',a[x]);
     end;
     writeln;
     for x:=1 to 8 do
     begin
          if a[x] mod 2=0 then a[x]:=a[x]*5
             else a[x]:=a[x]-2;
          writeln('a[',x,']:',a[x]);
     end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика