30 составьте программу для нахождения суммы трёх чисел, если хотя бы одно из них кратно 3, иначе модуль разности этих чисел.

гсооагвгв гсооагвгв    1   01.10.2019 15:40    1

Ответы
BlackStyle69 BlackStyle69  27.08.2020 10:54

var a,b,c:integer;

begin

read (a,b,c);

if (a mod 3 = 0) or (b mod 3 = 0) or (c mod 3 = 0) then write (a+b+c)

else write (abs(a-b-c))

end.

ПОКАЗАТЬ ОТВЕТЫ
Витаминка8990 Витаминка8990  27.08.2020 10:54

var x1,x2,x3:integer;

begin

writeln('Введите три числа');

readln(x1,x2,x3);

if (x1 mod 3=0)or(x2 mod 3=0)or(x3 mod 3=0) then

writeln('Сумма трех чисел = ',x1+x2+x3)

else writeln('Модуль разности трех чисел = ',abs(x1-x2-x3));

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика