(30 ! ): составить программу на языке паскаль для решения следующей : задать одномерный массив случайным образом, элементы которого принадлежат промежутку [-30; 40]; найти количество элементов массива, принадлежащих промежутку [-10; 25).

missvarvara2004 missvarvara2004    1   23.06.2019 11:00    1

Ответы
hickov2003 hickov2003  02.10.2020 09:16
Const
    n = 3;
var
  i,s:integer;
  a:array[1..n] of integer;
begin
  s:=0;
  for i:=1 to n do
   begin
     a[i]:=random(71)-30;
     if (a[i]>=-10) and (a[i]<25) then s:=s+1;
   end;
  writeln('Полученный массив:');
  for i:=1 to n do
   write('a[':4,i,']=',a[i]);
  writeln;
 write('Промежутку [-10;25) принадлежат ',s,' элемент(ов)');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика