30 ! программисту владу грустно: на дворе новый год, но он не может принести домой ёлку, потому что у его кота барсика аллергия. владу написать программу, принимающую на вход целое положительное число n, и выводящую на экран последовательность от 1 до n "ёлочкой", чтобы у влада хоть где-то она была. формат ввода строка, содержащая чило n. формат вывода ёлочка из нескольких строк. на python

dascha21schou dascha21schou    1   30.09.2019 23:40    176

Ответы
s2702e s2702e  02.09.2020 13:24

n = int(input())

 

q = 1

s = 1

k = 0

while q <= n :

   print(q, end=' ')

   q = q + 1

   k = k + 1

   if k == s :

       print()

       s = s + 1

       k = 0

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика