30 , паскальрешить каждую составить программу, печатающую значение true, если указанное высказывание является истинным, и false в противном случае: сумма цифр данного трехзначного числа n является четным числом.квадрат заданного трехзначного числа равен кубу суммы цифр этого числа.треугольник со сторонами a, b, c является равнобедренным.​

qwerty836 qwerty836    3   18.03.2019 19:27    7

Ответы
VladaCatVlada5 VladaCatVlada5  07.06.2020 03:39

Первая

var n,x:integer;

begin

 readln(n);

 while n <> 0 do begin

  x:=x + n mod 10;

  n:=n div 10;

 end;

 if(x mod 2 = 0) then

   writeln('true')

 else

   writeln('false');

end.

Вторая

var x,z,s:integer;

begin

 readln(x);

 if (x > 99) and (x < 1000) then begin

   s:=x;

   while s<>0 do begin

     z:=z+s mod 10;

     s:=s div 10;

   end;

   if(x*x) = (z*z*z) then

     writeln('true')

   else

     writeln('false');

 end

 else

   writeln('Число должно быть 3-ех значным!');

end.

Третья

Var a,b,c:Real;  

Begin  

 Writeln('Введите a');

 Readln(a);

 Writeln('Введите b');

 Readln(b);

 Writeln('Введите c');

 Readln(c);

 if (a=b) or (a=c) or (b=c) then

   writeln ('true')

 else

   writeln ('false);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика