30 напишите программу для решения следующей . в некотором году на участке в к гектаров средняя урожайность ячменя составила а центнеров с гектара. после этого каждый год площадь участка увеличивалась на р%, а средняя урожайность - на в%. через сколько лет урожай превысит м центнеров.

никита3473 никита3473    3   07.05.2019 07:50    700

Ответы
grugoryan85 grugoryan85  09.06.2020 14:26

program raf105;

var k,a,p,b,m,let:real;

begin

write('Площадь участка (га.): ');

readln(k);

write('Средняя урожайность с гектара (ц.): ');

readln(a);

write('Увеличение участка за год (% от площади): ');

readln(p);

write('Рост урожайности за год (% от урожайности): ');

readln(b);

write('Желаемый урожай (ц.): ');

readln(m);

while a < m do

begin

 k+= (k/100*p);

 a+= (a/100*b);

 let+= 1;

end;

writeln;

writeln('Желаемая урожайность (',m,' ц.) будет достигнута через ',let,' лет');

writeln('При этом, площадь участка будет составлять примерно ',round(k),' га.');

end.

Язык PascalABC

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика