tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
(30 )) на паскаль : дано целое
(30 )) на паскаль : дано целое число n ( > 0). последовательность действительны х чисел ак определяется следующим образом : ао = 2, ак = 2 + 1 / а к -1 , к = 1,2, . вывести элементы ак
vanich2004z
2 17.07.2019 03:00
6
Ответы
SpaniGar
03.10.2020 06:07
Сначала - современное решение, каким оно должно быть:
// PascalABC.NET 3.0, сборка 1157 от 02.02.2016
begin
SeqGen(ReadInteger('k=')+1,2.0,x->2+1/x).Skip(1).Println;
end.
Тестовое решение:
k= 6
2.5 2.4 2.41666666666667 2.41379310344828 2.41428571428571 2.41420118343195
А теперь "школьный вариант":
// PascalABC.NET 3.0, сборка 1157 от 02.02.2016
var
i,k:integer;
a,a0:real;
begin
Write('k='); Read(k);
a0:=2;
for i:=1 to k do begin
a:=2+1/a0; a0:=a; Write(a,' ')
end
end.
Тестовое решение:
k=6
2.5 2.4 2.41666666666667 2.41379310344828 2.41428571428571 2.41420118343195
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
somovalelyЛеля15
19.05.2019 18:10
Вычислите сколько байтов занимает на св одна минута стереозаписи (частота дискретизации 44000 разрядность 16 битов) какова максимальная продолжительность стереозаписи на диске емкостью...
Himop
19.05.2019 18:10
Вводится число н. а за ним н целых чисел-элементов массива. обнулите все отрицательные элементы массива и посчитайте количество остальных. через паскаль абс...
kvaki257989
25.05.2020 12:21
Составить программу которая из слова «Информатизация» получает слово «Информация»...
hydraclaireau
25.05.2020 12:21
Пацанчики во Мой код: Var A, N, C: Integer; Begin Write( Введи первый сомножитель: ); Readln(A); Write( Введи второй сомножитель: ); Readln(N); C:= A + N; Writeln(A, + ,N, = ,C);...
Джарият111
23.10.2019 16:06
Напишите программу: напишите программу, которая заполняет массив из 10 элементов случайными числами на отрезке [–5; 5] и находит сумму ненулевых элементов. на языке паскаля...
slappy337
23.10.2019 16:05
Дан алгоритм. восстановите общую формулу для решения которой был написан этот алгоритм....
lol1049
23.10.2019 17:34
Напишите наименьшее трехзначное число, для которого истинно высказывание не (первая цифра четная) и не (последняя цифра нечётная)? ...
aleksа005005
23.10.2019 17:33
Рассчитать в тетради объём текстового файла, содержащего фразу «информатика - наука об информационных процессах и их автоматизации.»...
anakukla2
01.09.2019 18:00
)найти и выдать на печать все трехзначные числа, которые при умножении на 2 заканчиваются цифрой 8, а при умножении на 3 - цифрой 4. при отсутствии таких чисел - сообщить об этом...
chukovsema
19.01.2022 13:08
(python) нужно сделать домик как на картинке, заранее хочу поблагодарить за ....
Популярные вопросы
Велосипедист едет со скоростью 15км/ч. сколько километров он проедит за 5 часов....
3
Составить 7 предложений(сложных, распространённых) с местоимениями ты, вы...
1
Если неизвестное число умножить на 35 то получится1505...
2
Приобретя теплокровность, птицы перестали зависеть от изменений температуры окружающей...
3
Фонетический разбор слов: грустное и заячьи . нужно !...
2
Дать ответ . what did you do last week?...
2
Известно, что змеи являются злейшими врагами бурундуков, не найдя мертвую змею,...
2
Какие забавные случаи бывают с животными ....
3
1: найди натуральное число,которое делится нацело на числа 2, 3 и 5. 2: найди...
1
Какое предложение является безличным? 1) сад монтекки 2) идешь, на меня похож,...
2
// PascalABC.NET 3.0, сборка 1157 от 02.02.2016
begin
SeqGen(ReadInteger('k=')+1,2.0,x->2+1/x).Skip(1).Println;
end.
Тестовое решение:
k= 6
2.5 2.4 2.41666666666667 2.41379310344828 2.41428571428571 2.41420118343195
А теперь "школьный вариант":
// PascalABC.NET 3.0, сборка 1157 от 02.02.2016
var
i,k:integer;
a,a0:real;
begin
Write('k='); Read(k);
a0:=2;
for i:=1 to k do begin
a:=2+1/a0; a0:=a; Write(a,' ')
end
end.
Тестовое решение:
k=6
2.5 2.4 2.41666666666667 2.41379310344828 2.41428571428571 2.41420118343195