3. Точка А задана координатами X,Y. Написать программу, которая выводит слово «Принадлежит», если точка принадлежит
заштрихованной области
и «не принадлежит» в противном случае протестировать
программу для
точек (0,0), (2,2),
(0.5,0.5), (0.5,-1.5), (-0.5,0.5), (-2,-1), (-1,-2), (-1, 1), (2, 0).


3. Точка А задана координатами X,Y. Написать программу, которая выводит слово «Принадлежит», если то

diasj5kz diasj5kz    3   28.12.2020 18:03    65

Ответы
Dash528 Dash528  27.01.2021 18:08

program chik;

var x,y:real;

begin

readln(x,y);

if((y<=2)and(x>=-3)and(x<=2)and(y>=0))or

((y<=0)and(x>=-1)and(x<=1)and(y>=-1)and(x*x+y*y<=1))then

writeln('ПРИНАДЛЕЖИТ')else writeln('Не принадлежит');

end.

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика